Friday, May 27, 2011

L2 Bridging Loop due to EtherChannel Misconfiguration

Network Setup

CORE-01#sh run int fa0/1
Building configuration...

Current configuration : 120 bytes
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 10 mode on
end

CORE-01#
CORE-01#sh run int fa0/2
Building configuration...

Current configuration : 120 bytes
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 10 mode on
end

CORE-01#
CORE-01#sh run int po10
Building configuration...

Current configuration : 93 bytes
!
interface Port-channel10
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

CORE-01#
CORE-01#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
CORE-02          Fas 0/2           139              S I   WS-C3560- Fas 0/2
CORE-02          Fas 0/1           136              S I   WS-C3560- Fas 0/1
CORE-01#
CORE-01#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SU)         -        Fa0/1(P)    Fa0/2(P)

CORE-01#
CORE-01#sh standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl11        1    110 P Active  local           192.168.1.3     192.168.1.1
Vl12        2    100 P Standby 192.168.2.3     local           192.168.2.1
CORE-01#
CORE-01#sh spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     0011.2007.6c00
             Cost        12
             Port        128 (Port-channel10)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0023.04a3.5c80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Po10                Root FWD 12        128.128  P2p



VLAN0011
  Spanning tree enabled protocol ieee
  Root ID    Priority    11
             Address     0023.04a3.5c80
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    11     (priority 0 sys-id-ext 11)
             Address     0023.04a3.5c80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Po10                Desg FWD 12        128.128  P2p



VLAN0012
  Spanning tree enabled protocol ieee
  Root ID    Priority    12
             Address     0011.2007.6c00
             Cost        12
             Port        128 (Port-channel10)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32780  (priority 32768 sys-id-ext 12)
             Address     0023.04a3.5c80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Po10                Root FWD 12        128.128  P2p


CORE-01#
================================================================================
CORE-02#sh run int fa0/1
Building configuration...

Current configuration : 120 bytes
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 10 mode on
end

CORE-02#
CORE-02#sh run int fa0/2
Building configuration...

Current configuration : 120 bytes
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 10 mode on
end

CORE-02#
CORE-02#sh run int po10
Building configuration...

Current configuration : 93 bytes
!
interface Port-channel10
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

CORE-02#
CORE-02#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
CORE-01          Fas 0/2           172              S I   WS-C3560- Fas 0/2
CORE-01          Fas 0/1           169              S I   WS-C3560- Fas 0/1
CORE-02#
CORE-02#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SU)         -        Fa0/1(P)    Fa0/2(P)

CORE-02#
CORE-02#sh standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl11        1    100 P Standby 192.168.1.2     local           192.168.1.1
Vl12        2    110 P Active  local           192.168.2.2     192.168.2.1
CORE-02#
CORE-02#sh spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     0011.2007.6c00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0011.2007.6c00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Po10                Desg FWD 12        128.128  P2p



VLAN0011
  Spanning tree enabled protocol ieee
  Root ID    Priority    11
             Address     0023.04a3.5c80
             Cost        12
             Port        128 (Port-channel10)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32779  (priority 32768 sys-id-ext 11)
             Address     0011.2007.6c00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Po10                Root FWD 12        128.128  P2p



VLAN0012
  Spanning tree enabled protocol ieee
  Root ID    Priority    12
             Address     0011.2007.6c00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    12     (priority 0 sys-id-ext 12)
             Address     0011.2007.6c00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Po10                Desg FWD 12        128.128  P2p


CORE-02#


Scenario #1


! Scenario #1 - CORE-01 and CORE-02 mode desirable, ACC-01 mode on.
CORE-01#sh run int fa0/3
Building configuration...

Current configuration : 126 bytes
!
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
end

CORE-01#
CORE-01#sh run int fa0/4
Building configuration...

Current configuration : 126 bytes
!
interface FastEthernet0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
end

CORE-01#
CORE-01#sh run int po1
Building configuration...

Current configuration : 92 bytes
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

CORE-01#
================================================================================
CORE-02#sh run int fa0/3
Building configuration...

Current configuration : 126 bytes
!
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
end

CORE-02#
CORE-02#sh run int fa0/4
Building configuration...

Current configuration : 126 bytes
!
interface FastEthernet0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
end

CORE-02#
CORE-02#sh run int po1
Building configuration...

Current configuration : 92 bytes
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

CORE-02#
================================================================================
ACC-01#sh run int fa0/1
Building configuration...

Current configuration : 81 bytes
!
interface FastEthernet0/1
 switchport mode trunk
 channel-group 1 mode on
end

ACC-01#
ACC-01#sh run int fa0/2
Building configuration...

Current configuration : 81 bytes
!
interface FastEthernet0/2
 switchport mode trunk
 channel-group 1 mode on
end

ACC-01#
ACC-01#sh run int fa0/3
Building configuration...

Current configuration : 81 bytes
!
interface FastEthernet0/3
 switchport mode trunk
 channel-group 2 mode on
end

ACC-01#
ACC-01#sh run int fa0/4
Building configuration...

Current configuration : 81 bytes
!
interface FastEthernet0/4
 switchport mode trunk
 channel-group 2 mode on
end

ACC-01#
ACC-01#sh run int po1
Building configuration...

Current configuration : 54 bytes
!
interface Port-channel1
 switchport mode trunk
end

ACC-01#
ACC-01#sh run int po2
Building configuration...

Current configuration : 54 bytes
!
interface Port-channel2
 switchport mode trunk
end

ACC-01#
================================================================================
ACC-01#
00:30:57: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:30:57: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
00:30:58: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
00:30:58: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
00:30:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
00:30:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
00:31:00: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:31:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
00:31:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
00:31:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
00:31:01: %LINK-3-UPDOWN: Interface Port-channel2, changed state to up
00:31:02: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel2, changed state to up
ACC-01#
ACC-01#sh etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)          -        Fa0/1(Pd)   Fa0/2(P)
2      Po2(SU)          -        Fa0/3(Pd)   Fa0/4(P)

ACC-01#
00:32:22: %PM-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Fa0/1 in err-disable state
00:32:22: %PM-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Fa0/2 in err-disable state
00:32:22: %PM-4-ERR_DISABLE: channel-misconfig error detected on Po2, putting Fa0/3 in err-disable state
00:32:22: %PM-4-ERR_DISABLE: channel-misconfig error detected on Po2, putting Fa0/4 in err-disable state
00:32:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
00:32:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
00:32:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to down
00:32:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
00:32:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
00:32:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel2, changed state to down
00:32:24: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to down
00:32:24: %LINK-3-UPDOWN: Interface Port-channel1, changed state to down
00:32:24: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to down
00:32:24: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down
00:32:24: %LINK-3-UPDOWN: Interface Port-channel2, changed state to down
00:32:24: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to down
ACC-01#
================================================================================
CORE-01#
00:30:02.183: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
00:30:02.728: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
00:30:13.608: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
00:30:14.078: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
CORE-01#
CORE-01#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)         PAgP      Fa0/3(I)    Fa0/4(I)
10     Po10(SU)         -        Fa0/1(P)    Fa0/2(P)

CORE-01#
00:31:29.064: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
00:31:29.148: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
00:31:30.079: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down
00:31:30.163: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to down
CORE-01#
================================================================================
CORE-02#
00:29:59.943: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
00:30:00.404: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
00:30:11.024: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
00:30:11.830: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
CORE-02#
CORE-02#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)         PAgP      Fa0/3(I)    Fa0/4(I)
10     Po10(SU)         -        Fa0/1(P)    Fa0/2(P)

CORE-02#
00:31:25.876: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
00:31:25.918: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
00:31:26.891: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down
00:31:26.933: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to down
CORE-02#


Scenario #2


! Scenario #2 - CORE-01 and CORE-02 mode on, ACC-01 mode desirable.
CORE-01#sh run int fa0/3
Building configuration...

Current configuration : 119 bytes
!
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on
end

CORE-01#
CORE-01#sh run int fa0/4
Building configuration...

Current configuration : 119 bytes
!
interface FastEthernet0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on
end

CORE-01#
CORE-01#sh run int po1
Building configuration...

Current configuration : 92 bytes
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

CORE-01#
================================================================================
CORE-02#sh run int fa0/3
Building configuration...

Current configuration : 119 bytes
!
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on
end

CORE-02#
CORE-02#sh run int fa0/4
Building configuration...

Current configuration : 119 bytes
!
interface FastEthernet0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on
end

CORE-02#
CORE-02#sh run int po1
Building configuration...

Current configuration : 92 bytes
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

CORE-02#
================================================================================
ACC-01#sh run int fa0/1
Building configuration...

Current configuration : 88 bytes
!
interface FastEthernet0/1
 switchport mode trunk
 channel-group 1 mode desirable
end

ACC-01#
ACC-01#sh run int fa0/2
Building configuration...

Current configuration : 88 bytes
!
interface FastEthernet0/2
 switchport mode trunk
 channel-group 1 mode desirable
end

ACC-01#
ACC-01#sh run int fa0/3
Building configuration...

Current configuration : 88 bytes
!
interface FastEthernet0/3
 switchport mode trunk
 channel-group 2 mode desirable
end

ACC-01#
ACC-01#sh run int fa0/4
Building configuration...

Current configuration : 88 bytes
!
interface FastEthernet0/4
 switchport mode trunk
 channel-group 2 mode desirable
end

ACC-01#
ACC-01#sh run int po1
Building configuration...

Current configuration : 54 bytes
!
interface Port-channel1
 switchport mode trunk
end

ACC-01#
ACC-01#sh run int po2
Building configuration...

Current configuration : 54 bytes
!
interface Port-channel2
 switchport mode trunk
end

ACC-01#
================================================================================
ACC-01#
00:48:46: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:48:47: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
00:48:47: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
00:48:48: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
00:48:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
00:48:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
00:48:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
00:48:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
ACC-01#
ACC-01#sh etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)         PAgP      Fa0/1(I)    Fa0/2(I)
2      Po2(SD)         PAgP      Fa0/3(I)    Fa0/4(I)

ACC-01#
ACC-01#sh spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     0011.2007.6c00
             Cost        19
             Port        3 (FastEthernet0/3)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0011.2029.6800
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Altn BLK 19        128.1    P2p
Fa0/2            Desg FWD 19        128.2    P2p
Fa0/3            Root FWD 19        128.3    P2p
Fa0/4            Desg FWD 19        128.4    P2p


VLAN0011
  Spanning tree enabled protocol ieee
  Root ID    Priority    11
             Address     0023.04a3.5c80
             Cost        19
             Port        1 (FastEthernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32779  (priority 32768 sys-id-ext 11)
             Address     0011.2029.6800
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Root FWD 19        128.1    P2p
Fa0/2            Desg FWD 19        128.2    P2p
Fa0/3            Altn BLK 19        128.3    P2p
Fa0/4            Desg FWD 19        128.4    P2p


VLAN0012
  Spanning tree enabled protocol ieee
  Root ID    Priority    12
             Address     0011.2007.6c00
             Cost        19
             Port        3 (FastEthernet0/3)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32780  (priority 32768 sys-id-ext 12)
             Address     0011.2029.6800
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Altn BLK 19        128.1    P2p
Fa0/2            Desg FWD 19        128.2    P2p
Fa0/3            Root FWD 19        128.3    P2p
Fa0/4            Desg FWD 19        128.4    P2p

ACC-01#
================================================================================
CORE-01#
00:47:51.856: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
00:47:52.485: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
00:47:53.878: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
00:47:54.499: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
00:47:54.868: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:47:55.874: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
00:48:38.992: %SW_MATM-4-MACFLAP_NOTIF: Host 0011.2007.6c41 in vlan 11 is flapping between port Po1 and port Po10
00:48:51.382: %SW_MATM-4-MACFLAP_NOTIF: Host 0011.2007.6c41 in vlan 11 is flapping between port Po10 and port Po1
00:49:06.079: %SW_MATM-4-MACFLAP_NOTIF: Host 0011.2007.6c41 in vlan 11 is flapping between port Po10 and port Po1
CORE-01#
CORE-01#sh proc cpu hist

    7777777777777777777777777777744444
    3333222222222233333333332222233333444445555444445555544444
100
 90
 80
 70 *****************************
 60 *****************************
 50 *****************************
 40 **********************************
 30 **********************************
 20 **********************************
 10 **********************************     ****     *****
   0....5....1....1....2....2....3....3....4....4....5....5....
             0    5    0    5    0    5    0    5    0    5
               CPU% per second (last 60 seconds)

     67616771  3    1 2    111  4   4 2 4 4 3211114
    66074910157876660937666312563677256726269945446
100
 90
 80
 70  *#* *#*
 60  *#* *#*
 50  *#* *#*                                      *
 40  *## *##   *                *   *   * * *     *
 30  ### *##   *                *   * * * * **    *
 20  ### *##   *      *         *   * * * * ** *  *
 10 *########**##***####*#*###**#***#*#*###*#######
   0....5....1....1....2....2....3....3....4....4....5....5....
             0    5    0    5    0    5    0    5    0    5
               CPU% per minute (last 60 minutes)
              * = maximum CPU%   # = average CPU%



100
 90
 80
 70
 60
 50
 40
 30
 20
 10
   0....5....1....1....2....2....3....3....4....4....5....5....6....6....7.
             0    5    0    5    0    5    0    5    0    5    0    5    0
                   CPU% per hour (last 72 hours)
                  * = maximum CPU%   # = average CPU%

CORE-01#
CORE-01#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.2.2             -   0023.04a3.5cc2  ARPA   Vlan12
Internet  192.168.1.1             -   0000.0c07.ac01  ARPA   Vlan11
Internet  192.168.1.2             -   0023.04a3.5cc1  ARPA   Vlan11
CORE-01#
CORE-01#sh standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl11        1    110 P Active  local           192.168.1.3     192.168.1.1
Vl12        2    100 P Standby 192.168.2.3     local           192.168.2.1
CORE-01#
00:49:20.171: %SW_MATM-4-MACFLAP_NOTIF: Host 0011.2007.6c41 in vlan 11 is flapping between port Po10 and port Po1
00:49:35.858: %SW_MATM-4-MACFLAP_NOTIF: Host 0011.2007.6c41 in vlan 11 is flapping between port Po10 and port Po1
00:49:52.468: %SW_MATM-4-MACFLAP_NOTIF: Host 0011.2007.6c41 in vlan 11 is flapping between port Po10 and port Po1
00:50:08.112: %SW_MATM-4-MACFLAP_NOTIF: Host 0011.2007.6c41 in vlan 11 is flapping between port Po10 and port Po1
00:50:22.960: %SW_MATM-4-MACFLAP_NOTIF: Host 0011.2007.6c41 in vlan 11 is flapping between port Po10 and port Po1
00:50:36.877: %SW_MATM-4-MACFLAP_NOTIF: Host 0011.2007.6c41 in vlan 11 is flapping between port Po10 and port Po1
00:50:52.069: %SW_MATM-4-MACFLAP_NOTIF: Host 0011.2007.6c41 in vlan 11 is flapping between port Po10 and port Po1
00:51:11.186: %SW_MATM-4-MACFLAP_NOTIF: Host 0011.2007.6c41 in vlan 11 is flapping between port Po10 and port Po1
CORE-01#
================================================================================
CORE-02#
00:47:49.751: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
00:47:50.120: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
00:47:51.772: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
00:47:52.133: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
00:47:52.754: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:47:53.760: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
00:48:39.495: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.04a3.5cc2 in vlan 12 is flapping between port Po1 and port Po10
00:48:50.325: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.04a3.5cc2 in vlan 12 is flapping between port Po1 and port Po10
00:49:07.152: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.04a3.5cc2 in vlan 12 is flapping between port Po10 and port Po1
CORE-02#
CORE-02#sh proc cpu hist

    7777777777777777777777777777776666622222
    8888800000222223333300000222229999933333777777777777777777
100
 90
 80 *****
 70 ***********************************
 60 ***********************************
 50 ***********************************
 40 ***********************************
 30 ***********************************
 20 ****************************************
 10 **********************************************************
   0....5....1....1....2....2....3....3....4....4....5....5....
             0    5    0    5    0    5    0    5    0    5
               CPU% per second (last 60 seconds)

     7881 771  4     121     1   3  4 424 4 4311114
    98001986878087889125788787788899484858383365760
100
 90
 80  *#*  **
 70  *##  **
 60  *##  ##
 50  *##  ##                            *
 40  *##  ##   *                 *  * * * * *     *
 30  *##  ##   *                 *  * *** * **    *
 20  *##  ##*  *      **     *   *  * *** * ******#
 10 ###############################################
   0....5....1....1....2....2....3....3....4....4....5....5....
             0    5    0    5    0    5    0    5    0    5
               CPU% per minute (last 60 minutes)
              * = maximum CPU%   # = average CPU%



100
 90
 80
 70
 60
 50
 40
 30
 20
 10
   0....5....1....1....2....2....3....3....4....4....5....5....6....6....7.
             0    5    0    5    0    5    0    5    0    5    0    5    0
                   CPU% per hour (last 72 hours)
                  * = maximum CPU%   # = average CPU%

CORE-02#
CORE-02#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.2.3             -   0011.2007.6c43  ARPA   Vlan12
Internet  192.168.1.3             -   0011.2007.6c41  ARPA   Vlan11
Internet  192.168.2.1             -   0000.0c07.ac02  ARPA   Vlan12
CORE-02#
CORE-02#sh standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl11        1    100 P Standby 192.168.1.2     local           192.168.1.1
Vl12        2    110 P Active  local           192.168.2.2     192.168.2.1
CORE-02#
00:49:21.144: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.04a3.5cc2 in vlan 12 is flapping between port Po10 and port Po1
00:49:35.346: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.04a3.5cc2 in vlan 12 is flapping between port Po10 and port Po1
00:49:51.360: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.04a3.5cc2 in vlan 12 is flapping between port Po10 and port Po1
00:49:56.553: %HSRP-5-STATECHANGE: Vlan11 Grp 1 state Standby -> Active
00:49:56.721: %HSRP-5-STATECHANGE: Vlan11 Grp 1 state Active -> Speak
00:50:01.670: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.04a3.5cc2 in vlan 12 is flapping between port Po10 and port Po1
00:50:08.314: %HSRP-5-STATECHANGE: Vlan11 Grp 1 state Speak -> Standby
CORE-02#
CORE-02#sh standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl11        1    100 P Standby 192.168.1.2     local           192.168.1.1
Vl12        2    110 P Active  local           192.168.2.2     192.168.2.1
CORE-02#
00:50:20.771: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.04a3.5cc2 in vlan 12 is flapping between port Po1 and port Po10
00:50:22.440: %HSRP-5-STATECHANGE: Vlan11 Grp 1 state Standby -> Active
CORE-02#
CORE-02#sh standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl11        1    100 P Active  local           unknown         192.168.1.1
Vl12        2    110 P Active  local           192.168.2.2     192.168.2.1
CORE-02#
00:50:30.552: %HSRP-5-STATECHANGE: Vlan11 Grp 1 state Active -> Speak
00:50:34.360: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.04a3.5cc2 in vlan 12 is flapping between port Po1 and port Po10
00:50:40.685: %HSRP-5-STATECHANGE: Vlan11 Grp 1 state Speak -> Standby
00:50:48.134: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.04a3.5cc2 in vlan 12 is flapping between port Po10 and port Po1
00:51:04.626: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.04a3.5cc2 in vlan 12 is flapping between port Po10 and port Po1
00:51:17.956: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.04a3.5cc2 in vlan 12 is flapping between port Po1 and port Po10
CORE-02#

No comments:

Post a Comment