Friday, June 3, 2011

BGP Confederation Quick Shot


Configuration and BGP table on RT1:
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet1/0
 ip address 12.12.12.1 255.255.255.0
 duplex full
!
router bgp 65101
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 192.168.1.0
 neighbor 2.2.2.2 remote-as 65102
 neighbor 2.2.2.2 ebgp-multihop 255
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
!
ip route 2.2.2.2 255.255.255.255 12.12.12.2
!
RT1#sh ip bgp
BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.1.0      0.0.0.0                  0         32768 i
*> 192.168.2.0      2.2.2.2                                0 65102 65103 i
RT1#
RT1#ping 192.168.2.1 source 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/40/76 ms
RT1#

Configuration and BGP table on RT2:
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Ethernet1/0
 ip address 12.12.12.2 255.255.255.0
 duplex full
!
interface Ethernet1/1
 ip address 24.24.24.2 255.255.255.0
 duplex full
!
interface Ethernet1/2
 ip address 23.23.23.2 255.255.255.0
 duplex full
!
router bgp 61
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 bgp confederation identifier 65102
 bgp confederation peers 62 63
 neighbor 1.1.1.1 remote-as 65101
 neighbor 1.1.1.1 ebgp-multihop 255
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 3.3.3.3 remote-as 61
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 3.3.3.3 next-hop-self
 neighbor 4.4.4.4 remote-as 62
 neighbor 4.4.4.4 ebgp-multihop 255
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 4.4.4.4 next-hop-self
 no auto-summary
!
ip route 1.1.1.1 255.255.255.255 12.12.12.1
ip route 3.3.3.3 255.255.255.255 23.23.23.3
ip route 4.4.4.4 255.255.255.255 24.24.24.4
!
RT2#sh ip bgp
BGP table version is 3, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.1.0      1.1.1.1                  0             0 65101 i
*> 192.168.2.0      4.4.4.4                  0    100      0 (62 63) 65103 i
RT2#

Configuration and BGP table on RT3:
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Ethernet1/0
 ip address 23.23.23.3 255.255.255.0
 duplex full
!
router bgp 61
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 bgp confederation identifier 65102
 bgp confederation peers 62 63
 neighbor 2.2.2.2 remote-as 61
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
!
ip route 2.2.2.2 255.255.255.255 23.23.23.2
!
RT3#sh ip bgp
BGP table version is 3, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i192.168.1.0      2.2.2.2                  0    100      0 65101 i
*>i192.168.2.0      2.2.2.2                  0    100      0 (62 63) 65103 i
RT3#

Configuration and BGP table on RT4:
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Ethernet1/0
 ip address 24.24.24.4 255.255.255.0
 duplex full
!
interface Ethernet1/1
 ip address 45.45.45.4 255.255.255.0
 duplex full
!
router bgp 62
 no synchronization
 bgp router-id 4.4.4.4
 bgp log-neighbor-changes
 bgp confederation identifier 65102
 bgp confederation peers 61 63
 neighbor 2.2.2.2 remote-as 61
 neighbor 2.2.2.2 ebgp-multihop 255
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 next-hop-self
 neighbor 5.5.5.5 remote-as 62
 neighbor 5.5.5.5 update-source Loopback0
 neighbor 5.5.5.5 next-hop-self
 no auto-summary
!
ip route 2.2.2.2 255.255.255.255 24.24.24.2
ip route 5.5.5.5 255.255.255.255 45.45.45.5
!
RT4#sh ip bgp
BGP table version is 3, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.1.0      2.2.2.2                  0    100      0 (61) 65101 i
*>i192.168.2.0      5.5.5.5                  0    100      0 (63) 65103 i
RT4#

Configuration and BGP table on RT5:
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface Ethernet1/0
 ip address 45.45.45.5 255.255.255.0
 duplex full
!
interface Ethernet1/1
 ip address 57.57.57.5 255.255.255.0
 duplex full
!
router bgp 62
 no synchronization
 bgp router-id 5.5.5.5
 bgp log-neighbor-changes
 bgp confederation identifier 65102
 bgp confederation peers 61 63
 neighbor 4.4.4.4 remote-as 62
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 4.4.4.4 next-hop-self
 neighbor 7.7.7.7 remote-as 63
 neighbor 7.7.7.7 ebgp-multihop 255
 neighbor 7.7.7.7 update-source Loopback0
 neighbor 7.7.7.7 next-hop-self
 no auto-summary
!
ip route 4.4.4.4 255.255.255.255 45.45.45.4
ip route 7.7.7.7 255.255.255.255 57.57.57.7
!
RT5#sh ip bgp
BGP table version is 3, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i192.168.1.0      4.4.4.4                  0    100      0 (61) 65101 i
*> 192.168.2.0      7.7.7.7                  0    100      0 (63) 65103 i
RT5#

Configuration and BGP table on RT6:
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface Ethernet1/0
 ip address 67.67.67.6 255.255.255.0
 duplex full
!
router bgp 63
 no synchronization
 bgp router-id 6.6.6.6
 bgp log-neighbor-changes
 bgp confederation identifier 65102
 bgp confederation peers 61 62
 neighbor 7.7.7.7 remote-as 63
 neighbor 7.7.7.7 update-source Loopback0
 no auto-summary
!
ip route 7.7.7.7 255.255.255.255 67.67.67.7
!
RT6#sh ip bgp
BGP table version is 3, local router ID is 6.6.6.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i192.168.1.0      7.7.7.7                  0    100      0 (62 61) 65101 i
*>i192.168.2.0      7.7.7.7                  0    100      0 65103 i
RT6#

Configuration and BGP table on RT7:
!
interface Loopback0
 ip address 7.7.7.7 255.255.255.255
!
interface Ethernet1/0
 ip address 67.67.67.7 255.255.255.0
 duplex full
!
interface Ethernet1/1
 ip address 57.57.57.7 255.255.255.0
 duplex full
!
interface Ethernet1/2
 ip address 78.78.78.7 255.255.255.0
 duplex full
!
router bgp 63
 no synchronization
 bgp router-id 7.7.7.7
 bgp log-neighbor-changes
 bgp confederation identifier 65102
 bgp confederation peers 61 62
 neighbor 5.5.5.5 remote-as 62
 neighbor 5.5.5.5 ebgp-multihop 255
 neighbor 5.5.5.5 update-source Loopback0
 neighbor 5.5.5.5 next-hop-self
 neighbor 6.6.6.6 remote-as 63
 neighbor 6.6.6.6 update-source Loopback0
 neighbor 6.6.6.6 next-hop-self
 neighbor 8.8.8.8 remote-as 65103
 neighbor 8.8.8.8 ebgp-multihop 255
 neighbor 8.8.8.8 update-source Loopback0
 no auto-summary
!
ip route 5.5.5.5 255.255.255.255 57.57.57.5
ip route 6.6.6.6 255.255.255.255 67.67.67.6
ip route 8.8.8.8 255.255.255.255 78.78.78.8
!
RT7#sh ip bgp
BGP table version is 3, local router ID is 7.7.7.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.1.0      5.5.5.5                  0    100      0 (62 61) 65101 i
*> 192.168.2.0      8.8.8.8                  0             0 65103 i
RT7#

Configuration and BGP table on RT8:
!
interface Loopback0
 ip address 8.8.8.8 255.255.255.255
!
interface Loopback1
 ip address 192.168.2.1 255.255.255.0
!
interface Ethernet1/0
 ip address 78.78.78.8 255.255.255.0
 duplex full
!
router bgp 65103
 no synchronization
 bgp router-id 8.8.8.8
 bgp log-neighbor-changes
 network 192.168.2.0
 neighbor 7.7.7.7 remote-as 65102
 neighbor 7.7.7.7 ebgp-multihop 255
 neighbor 7.7.7.7 update-source Loopback0
 no auto-summary
!
ip route 7.7.7.7 255.255.255.255 78.78.78.7
!
RT8#sh ip bgp
BGP table version is 3, local router ID is 8.8.8.8
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.1.0      7.7.7.7                                0 65102 65101 i
*> 192.168.2.0      0.0.0.0                  0         32768 i
RT8#

No comments:

Post a Comment