Saturday, June 25, 2011

Nexus 5000 vPC Failover Scenarios


N5K-01-config
hostname N5K-01

feature interface-vlan
feature lacp
feature vpc

vlan 10
  name Management_VLAN
vlan 88
  name vPC-Peer-Keepalive_VLAN

vpc domain 1
  role priority 100
  peer-keepalive destination 1.1.1.2 source 1.1.1.1 vrf default

int vlan 10
  desc *** Management IP ***
  ip add 192.168.1.11 255.255.255.0
  no shutdown

int vlan 88
  description *** vPC Peer Keepalive ***
  ip address 1.1.1.1/30
  no shutdown

interface port-channel1
  desc *** C2960G Po1 ***
  switchport mode trunk
  vpc 1
  switchport trunk allowed vlan 10

interface port-channel10
  description *** vPC Peer Link ***
  switchport mode trunk
  vpc peer-link
  switchport trunk allowed vlan 10
  spanning-tree port type network

interface Ethernet1/1
  desc *** C2960G Gi0/1 ***
  speed 1000
  switchport mode trunk
  switchport trunk allowed vlan 10
  channel-group 1 mode active

interface Ethernet1/5
  desc *** N5K-02 Eth1/5 ***
  switchport mode trunk
  switchport trunk allowed vlan 10
  spanning-tree port type network
  channel-group 10 mode active

interface Ethernet1/6
  desc *** N5K-02 Eth1/6 ***
  switchport mode trunk
  switchport trunk allowed vlan 10
  spanning-tree port type network
  channel-group 10 mode active

interface Ethernet1/7
  desc *** N5K-02 Eth1/7 ***
  switchport access vlan 88

interface Ethernet1/8
  speed 1000
  switchport mode access
  switchport access vlan 10
  spanning-tree port type edge

N5K-02-config
hostname N5K-02

feature interface-vlan
feature lacp
feature vpc

vlan 10
  name Management_VLAN
vlan 88
  name vPC-Peer-Keepalive_VLAN

vpc domain 1
  role priority 110
  peer-keepalive destination 1.1.1.1 source 1.1.1.2 vrf default

int vlan 10
  desc *** Management IP ***
  ip add 192.168.1.12 255.255.255.0
  no shutdown

int vlan 88
  description *** vPC Peer Keepalive ***
  ip address 1.1.1.2/30
  no shutdown

interface port-channel1
  desc *** C2960G Po1 ***
  switchport mode trunk
  vpc 1
  switchport trunk allowed vlan 10

interface port-channel10
  description *** vPC Peer Link ***
  switchport mode trunk
  vpc peer-link
  switchport trunk allowed vlan 10
  spanning-tree port type network

interface Ethernet1/1
  desc *** C2960G Gi0/2 ***
  speed 1000
  switchport mode trunk
  switchport trunk allowed vlan 10
  channel-group 1 mode active

interface Ethernet1/5
  desc *** N5K-01 Eth1/5 ***
  switchport mode trunk
  switchport trunk allowed vlan 10
  spanning-tree port type network
  channel-group 10 mode active

interface Ethernet1/6
  desc *** N5K-01 Eth1/6 ***
  switchport mode trunk
  switchport trunk allowed vlan 10
  spanning-tree port type network
  channel-group 10 mode active

interface Ethernet1/7
  desc *** N5K-01 Eth1/7 ***
  switchport access vlan 88

interface Ethernet1/8
  speed 1000
  switchport mode access
  switchport access vlan 10
  spanning-tree port type edge



Scenario 0 - Normal Operation

N5K-01# sh cdp neighbors
Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater,
                  V - VoIP-Phone, D - Remotely-Managed-Device,
                  s - Supports-STP-Dispute


Device-ID             Local Intrfce Hldtme Capability  Platform      Port ID

C2960G                Eth1/1        166    S I       WS-C2960G-24T Gig0/1
N5K-02(SSI1429041X)   Eth1/5        144    S I s     N5K-C5010P-BF Eth1/5
N5K-02(SSI1429041X)   Eth1/6        142    S I s     N5K-C5010P-BF Eth1/6
N5K-02(SSI1429041X)   Eth1/7        165    S I s     N5K-C5010P-BF Eth1/7
N5K-01#
N5K-01# sh run vpc

!Command: show running-config vpc
!Time: Wed Jun 15 05:54:42 2011

version 4.2(1)N2(1)
feature vpc

vpc domain 1
  role priority 100
  peer-keepalive destination 1.1.1.2 source 1.1.1.1 vrf default


interface port-channel1
  vpc 1

interface port-channel10
  vpc peer-link

N5K-01#
N5K-01# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer adjacency formed ok
vPC keep-alive status           : peer is alive
Configuration consistency status: success
vPC role                        : primary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     10

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-01#
N5K-01# sh vpc role

vPC Role status
----------------------------------------------------
vPC role                        : primary
Dual Active Detection Status    : 0
vPC system-mac                  : 00:23:04:ee:be:01
vPC system-priority             : 32667
vPC local system-mac            : 00:05:73:af:fe:7c
vPC local role-priority         : 100
N5K-01#
N5K-01# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        1
             Port        4096 (port-channel1)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fe7c
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 1         128.4096 (vPC) P2p Peer(STP)
Po10             Desg FWD 1         128.4105 (vPC peer-link) Network P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-01#
N5K-01# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SU)    Eth      LACP      Eth1/5(P)    Eth1/6(P)
N5K-01#
================================================================================
N5K-02# sh cdp neighbors
Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater,
                  V - VoIP-Phone, D - Remotely-Managed-Device,
                  s - Supports-STP-Dispute


Device-ID             Local Intrfce Hldtme Capability  Platform      Port ID

C2960G                Eth1/1        162    S I       WS-C2960G-24T Gig0/2
N5K-01(SSI1429065H)   Eth1/5        136    S I s     N5K-C5010P-BF Eth1/5
N5K-01(SSI1429065H)   Eth1/6        135    S I s     N5K-C5010P-BF Eth1/6
N5K-01(SSI1429065H)   Eth1/7        157    S I s     N5K-C5010P-BF Eth1/7
N5K-02#
N5K-02# sh run vpc

!Command: show running-config vpc
!Time: Wed Jun 15 05:58:45 2011

version 4.2(1)N2(1)
feature vpc

vpc domain 1
  role priority 110
  peer-keepalive destination 1.1.1.1 source 1.1.1.2 vrf default


interface port-channel1
  vpc 1

interface port-channel10
  vpc peer-link

N5K-02#
N5K-02# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer adjacency formed ok
vPC keep-alive status           : peer is alive
Configuration consistency status: success
vPC role                        : secondary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     10

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-02#
N5K-02# sh vpc role

vPC Role status
----------------------------------------------------
vPC role                        : secondary
Dual Active Detection Status    : 0
vPC system-mac                  : 00:23:04:ee:be:01
vPC system-priority             : 32667
vPC local system-mac            : 00:05:73:af:fa:fc
vPC local role-priority         : 110
N5K-02#
N5K-02# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        2
             Port        4105 (port-channel10)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fafc
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 1         128.4096 (vPC) P2p
Po10             Root FWD 1         128.4105 (vPC peer-link) Network P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-02#
N5K-02# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SU)    Eth      LACP      Eth1/5(P)    Eth1/6(P)
N5K-02#
================================================================================
C2960G#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi0/1(P)    Gi0/2(P)

C2960G#
================================================================================
PC1 (192.168.1.101) ping 192.168.1.1   - OK
PC1 (192.168.1.101) ping 192.168.1.11  - OK
PC1 (192.168.1.101) ping 192.168.1.12  - OK
PC1 (192.168.1.101) ping 192.168.1.102 – OK



Scenario 1 - N5K-01 E1/1 Down

N5K-01# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
N5K-01(config)# int e1/1
N5K-01(config-if)# shut
N5K-01(config-if)# end
N5K-01#
N5K-01# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer adjacency formed ok
vPC keep-alive status           : peer is alive
Configuration consistency status: success
vPC role                        : primary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     10

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         down*  success     success                    -

N5K-01#
N5K-01# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        1
             Port        4096 (port-channel1)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fe7c
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 1         128.4096 (vPC) P2p Peer(STP)
Po10             Desg FWD 1         128.4105 (vPC peer-link) Network P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-01#
N5K-01# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SD)     Eth      LACP      Eth1/1(D)
10    Po10(SU)    Eth      LACP      Eth1/5(P)    Eth1/6(P)
N5K-01#
================================================================================
N5K-02# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer adjacency formed ok
vPC keep-alive status           : peer is alive
Configuration consistency status: success
vPC role                        : secondary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     10

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-02#
N5K-02# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        2
             Port        4105 (port-channel10)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fafc
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 1         128.4096 (vPC) P2p
Po10             Root FWD 1         128.4105 (vPC peer-link) Network P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-02#
N5K-02# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SU)    Eth      LACP      Eth1/5(P)    Eth1/6(P)
N5K-02#
================================================================================
C2960G#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi0/1(D)    Gi0/2(P)

C2960G#
================================================================================
PC1 (192.168.1.101) ping 192.168.1.1   - OK
PC1 (192.168.1.101) ping 192.168.1.11  - OK
PC1 (192.168.1.101) ping 192.168.1.12  - OK
PC1 (192.168.1.101) ping 192.168.1.102 – OK



Scenario 2 - N5K-02 E1/1 Down

N5K-01# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
N5K-01(config)# int e1/1
N5K-01(config-if)# no shut
N5K-01(config-if)# end
N5K-01#
================================================================================
N5K-02# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
N5K-02(config)# int e1/1
N5K-02(config-if)# shut
N5K-02(config-if)# end
N5K-02#
================================================================================
N5K-01# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer adjacency formed ok
vPC keep-alive status           : peer is alive
Configuration consistency status: success
vPC role                        : primary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     10

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-01#
N5K-01# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        1
             Port        4096 (port-channel1)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fe7c
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 1         128.4096 (vPC) P2p Peer(STP)
Po10             Desg FWD 1         128.4105 (vPC peer-link) Network P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-01#
N5K-01# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SU)    Eth      LACP      Eth1/5(P)    Eth1/6(P)
N5K-01#
================================================================================
N5K-02# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer adjacency formed ok
vPC keep-alive status           : peer is alive
Configuration consistency status: success
vPC role                        : secondary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     10

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         down*  success     success                    -

N5K-02#
N5K-02# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        2
             Port        4105 (port-channel10)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fafc
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po10             Root FWD 1         128.4105 (vPC peer-link) Network P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-02#
N5K-02# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SD)     Eth      LACP      Eth1/1(D)
10    Po10(SU)    Eth      LACP      Eth1/5(P)    Eth1/6(P)
N5K-02#
================================================================================
C2960G#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi0/1(P)    Gi0/2(D)

C2960G#
================================================================================
PC1 (192.168.1.101) ping 192.168.1.1   - OK
PC1 (192.168.1.101) ping 192.168.1.11  - OK
PC1 (192.168.1.101) ping 192.168.1.12  - OK
PC1 (192.168.1.101) ping 192.168.1.102 – OK



Scenario 3 - vPC Peer Link Down

N5K-02# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
N5K-02(config)# int e1/1
N5K-02(config-if)# no shut
N5K-02(config-if)# end
N5K-02#
================================================================================
N5K-01# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
N5K-01(config)# int po10
N5K-01(config-if)# shut
N5K-01(config-if)# end
N5K-01#
N5K-01# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer link is down
vPC keep-alive status           : peer is alive
Configuration consistency status: success
vPC role                        : primary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   down   -

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-01#
N5K-01# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        1
             Port        4096 (port-channel1)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fe7c
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 1         128.4096 (vPC) P2p Peer(STP)
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-01#
N5K-01# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SD)    Eth      LACP      Eth1/5(D)    Eth1/6(D)
N5K-01#
================================================================================
N5K-02# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer link is down
vPC keep-alive status           : peer is alive
Configuration consistency status: success
vPC role                        : secondary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   down   -

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         down   failed      Peer-link is down          -

N5K-02#
N5K-02# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    32778
             Address     0005.73af.fafc
             This bridge is the root
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fafc
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-02#
N5K-02# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SD)     Eth      LACP      Eth1/1(D)
10    Po10(SD)    Eth      LACP      Eth1/5(D)    Eth1/6(D)
N5K-02#
================================================================================
C2960G#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi0/1(P)    Gi0/2(D)

C2960G#
================================================================================
PC1 (192.168.1.101) ping 192.168.1.1   - OK
PC1 (192.168.1.101) ping 192.168.1.11  - OK
PC1 (192.168.1.101) ping 192.168.1.12  - FAIL
PC1 (192.168.1.101) ping 192.168.1.102 – FAIL



Scenario 4 - vPC Peer Keepalive Link Down

N5K-01# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
N5K-01(config)# int po10
N5K-01(config-if)# no shut
N5K-01(config-if)# end
N5K-01#
================================================================================
PC1 (192.168.1.101) ping 192.168.1.1   - OK
PC1 (192.168.1.101) ping 192.168.1.11  - OK
PC1 (192.168.1.101) ping 192.168.1.12  - OK
PC1 (192.168.1.101) ping 192.168.1.102 - OK
================================================================================
N5K-01# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
N5K-01(config)# int e1/7
N5K-01(config-if)# shut
N5K-01(config-if)# end
N5K-01#
N5K-01# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer adjacency formed ok
vPC keep-alive status           : peer is not alive
Configuration consistency status: success
vPC role                        : primary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     10

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-01#
N5K-01# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        1
             Port        4096 (port-channel1)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fe7c
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 1         128.4096 (vPC) P2p Peer(STP)
Po10             Desg FWD 1         128.4105 (vPC peer-link) Network P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-01#
N5K-01# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SU)    Eth      LACP      Eth1/5(P)    Eth1/6(P)
N5K-01#
================================================================================
N5K-02# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer adjacency formed ok
vPC keep-alive status           : peer is not alive
Configuration consistency status: success
vPC role                        : secondary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     10

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-02#
N5K-02# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        2
             Port        4105 (port-channel10)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fafc
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 1         128.4096 (vPC) P2p
Po10             Root FWD 1         128.4105 (vPC peer-link) Network P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-02#
N5K-02# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SU)    Eth      LACP      Eth1/5(P)    Eth1/6(P)
N5K-02#
================================================================================
C2960G#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi0/1(P)    Gi0/2(P)

C2960G#
================================================================================
PC1 (192.168.1.101) ping 192.168.1.1   - OK
PC1 (192.168.1.101) ping 192.168.1.11  - OK
PC1 (192.168.1.101) ping 192.168.1.12  - OK
PC1 (192.168.1.101) ping 192.168.1.102 – OK



Scenario 5 - Both vPC Peer Link and vPC Peer Keepalive Link Down + Try To Reestablish vPC using only the vPC Peer Link

N5K-01# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
N5K-01(config)# int po10
N5K-01(config-if)# shut
N5K-01(config-if)#
N5K-01(config-if)# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer link is down
vPC keep-alive status           : Suspended (Destination IP not reachable)
Configuration consistency status: success
vPC role                        : primary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   down   -

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-01(config-if)#
N5K-01(config-if)# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        1
             Port        4096 (port-channel1)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fe7c
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 1         128.4096 (vPC) P2p Peer(STP)
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-01(config-if)#
N5K-01(config-if)# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SD)    Eth      LACP      Eth1/5(D)    Eth1/6(D)
N5K-01(config-if)#
================================================================================
N5K-02# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer link is down
vPC keep-alive status           : Suspended (Destination IP not reachable)
Configuration consistency status: success
vPC role                        : secondary, operational primary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   down   -

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-02#
N5K-02# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    32778
             Address     0005.73af.fafc
             This bridge is the root
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fafc
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Desg FWD 1         128.4096 (vPC) P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-02#
N5K-02# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SD)    Eth      LACP      Eth1/5(D)    Eth1/6(D)
N5K-02#
Note: C2960G does not receive any BPDU generated by N5K-02 upon Gi0/2.
================================================================================
C2960G#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi0/1(P)    Gi0/2(P)

C2960G#
================================================================================
PC1 (192.168.1.101) ping 192.168.1.1   - OK
PC1 (192.168.1.101) ping 192.168.1.11  - OK
PC1 (192.168.1.101) ping 192.168.1.12  - FAIL
PC1 (192.168.1.101) ping 192.168.1.102 - FAIL
================================================================================
N5K-01(config-if)# no shut
N5K-01(config-if)#
N5K-01(config-if)# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer link is down
                                  (peer-keepalive not operational,
                                  peer never alive)
vPC keep-alive status           : Suspended (Destination IP not reachable)
Configuration consistency status: success
vPC role                        : primary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     -

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-01(config-if)#
N5K-01(config-if)# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        1
             Port        4096 (port-channel1)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fe7c
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 1         128.4096 (vPC) P2p Peer(STP)
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-01(config-if)#
N5K-01(config-if)# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SU)    Eth      LACP      Eth1/5(P)    Eth1/6(P)
N5K-01(config-if)#
================================================================================
N5K-02# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer link is down
                                  (peer-keepalive not operational,
                                  peer never alive)
vPC keep-alive status           : Suspended (Destination IP not reachable)
Configuration consistency status: success
vPC role                        : secondary, operational primary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     -

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-02#
N5K-02# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    32778
             Address     0005.73af.fafc
             This bridge is the root
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fafc
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Desg FWD 1         128.4096 (vPC) P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-02#
N5K-02# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SU)    Eth      LACP      Eth1/5(P)    Eth1/6(P)
N5K-02#
================================================================================
C2960G#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi0/1(P)    Gi0/2(P)

C2960G#
================================================================================
N5K-01(config-if)# int e1/7
N5K-01(config-if)# no shut
N5K-01(config-if)#
N5K-01(config-if)# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer link is down
                                  (vPC peer is not reachable over
                                  cfs)
vPC keep-alive status           : peer is alive
Configuration consistency status: success
vPC role                        : primary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     -

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-01(config-if)#
N5K-01(config-if)# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    32778
             Address     0005.73af.fe7c
             This bridge is the root
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fe7c
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Desg BLK 1         128.4096 (vPC) P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-01(config-if)# 

N5K-01(config-if)# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer adjacency formed ok
vPC keep-alive status           : peer is alive
Configuration consistency status: success
vPC role                        : primary, operational secondary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     10

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-01(config-if)#
N5K-01(config-if)# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        2
             Port        4105 (port-channel10)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fe7c
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 1         128.4096 (vPC) P2p
Po10             Root FWD 1         128.4105 (vPC peer-link) Network P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-01(config-if)#
N5K-01(config-if)# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SU)    Eth      LACP      Eth1/5(P)    Eth1/6(P)
N5K-01(config-if)#
================================================================================
N5K-02# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer adjacency formed ok
vPC keep-alive status           : peer is alive
Configuration consistency status: success
vPC role                        : secondary, operational primary
Number of vPCs configured       : 1
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po10   up     10

vPC status
----------------------------------------------------------------------------
id     Port        Status Consistency Reason                     Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1      Po1         up     success     success                    10

N5K-02#
N5K-02# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     0021.565e.e200
             Cost        1
             Port        4096 (port-channel1)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.73af.fafc
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 1         128.4096 (vPC) P2p Peer(STP)
Po10             Desg FWD 1         128.4105 (vPC peer-link) Network P2p
Eth1/8           Desg FWD 4         128.136  Edge P2p

N5K-02#
N5K-02# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)
10    Po10(SU)    Eth      LACP      Eth1/5(P)    Eth1/6(P)
N5K-02#
================================================================================
C2960G#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi0/1(P)    Gi0/2(P)

C2960G#
================================================================================
PC1 (192.168.1.101) ping 192.168.1.1   - OK
PC1 (192.168.1.101) ping 192.168.1.11  - OK
PC1 (192.168.1.101) ping 192.168.1.12  - OK
PC1 (192.168.1.101) ping 192.168.1.102 – OK

No comments:

Post a Comment