Tuesday, November 29, 2011

Native VLAN Mismatch and VTP Domain

Summary:
1. The %CDP-4-NATIVE_VLAN_MISMATCH issue resolved when the switches reside in different VTP domains.
2. The VTP Transparent mode does not resolve the %CDP-4-NATIVE_VLAN_MISMATCH issue.

C2950#sh run int fa0/1
Building configuration...

Current configuration : 108 bytes
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
end

C2950#
C2950#sh run int vlan 10
Building configuration...

Current configuration : 81 bytes
!
interface Vlan10
 ip address 192.168.1.1 255.255.255.0
 no ip route-cache
end

C2950#
C2950#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
C2950#
C2950#sh cdp neighbors detail
-------------------------
Device ID: C3560
Entry address(es):
Platform: cisco WS-C3560-48TS,  Capabilities: Switch IGMP
Interface: FastEthernet0/1,  Port ID (outgoing port): FastEthernet0/1
Holdtime : 137 sec

Version :
Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 12.2(55)SE3,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Thu 05-May-11 16:14 by prod_rel_team

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0000000
0FFFFFFFF010221FF000000000000002304A35C80FF0000
VTP Management Domain: ''
Native VLAN: 20 (Mismatch)
Duplex: full
Management address(es):

C2950#
C2950#sh vtp status
VTP Version                     : 2
Configuration Revision          : 1
Maximum VLANs supported locally : 250
Number of existing VLANs        : 6
VTP Operating Mode              : Server
VTP Domain Name                 :
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xB1 0xBE 0x72 0x49 0x96 0x6D 0x99 0xA4
Configuration last modified by 0.0.0.0 at 3-1-93 00:03:55
Local updater ID is 192.168.1.1 on interface Vl10 (lowest numbered VLAN interface found)
C2950#
================================================================================
C3560#sh run int fa0/1
Building configuration...

Current configuration : 108 bytes
!
interface FastEthernet0/1
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
end

C3560#
C3560#sh run int vlan 20
Building configuration...

Current configuration : 62 bytes
!
interface Vlan20
 ip address 192.168.1.2 255.255.255.0
end

C3560#
C3560#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms
C3560#
C3560#sh cdp neighbors detail
-------------------------
Device ID: C2950
Entry address(es):
  IP address: 192.168.1.1
Platform: cisco WS-C2950T-24,  Capabilities: Switch IGMP
Interface: FastEthernet0/1,  Port ID (outgoing port): FastEthernet0/1
Holdtime : 166 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA14, RELEASE SOFTWA
RE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by cisco Systems, Inc.
Compiled Tue 26-Oct-10 10:35 by nburra

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0000000
0FFFFFFFF010221FF000000000000001120296800FF0000
VTP Management Domain: ''
Native VLAN: 10 (Mismatch)
Duplex: full
Management address(es):
  IP address: 192.168.1.1

C3560#
C3560#sh vtp status
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 :
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : 0023.04a3.5c80
Configuration last modified by 0.0.0.0 at 3-1-93 00:03:01
Local updater ID is 192.168.1.2 on interface Vl20 (lowest numbered VLAN interface found)

Feature VLAN:
--------------
VTP Operating Mode                : Server
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 6
Configuration Revision            : 1
MD5 digest                        : 0x05 0x05 0xF4 0x88 0xCB 0x99 0xA9 0x58
                                    0xD8 0xF6 0xC7 0xE0 0x38 0xCB 0x72 0x72
C3560#
================================================================================
C2950#
00:06:10: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/1 (10), with C3560 FastEthernet0/1 (20).
00:07:10: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/1 (10), with C3560 FastEthernet0/1 (20).
C2950#
================================================================================
C3560#
*Mar  1 00:05:17.936: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/1 (20), with C2950 FastEthernet0/1 (10).
*Mar  1 00:06:17.940: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/1 (20), with C2950 FastEthernet0/1 (10).
C3560#
================================================================================
C2950#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
C2950(config)#vtp domain Building01
Changing VTP domain name from NULL to Building01
C2950(config)#end
C2950#
C2950#sh vtp status
VTP Version                     : 2
Configuration Revision          : 1
Maximum VLANs supported locally : 250
Number of existing VLANs        : 6
VTP Operating Mode              : Server
VTP Domain Name                 : Building01
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x64 0xC2 0xA5 0x9E 0xD5 0x82 0x31 0xC4
Configuration last modified by 0.0.0.0 at 3-1-93 00:03:55
Local updater ID is 192.168.1.1 on interface Vl10 (lowest numbered VLAN interfac
e found)
C2950#
C2950#sh cdp neighbors detail
-------------------------
Device ID: C3560
Entry address(es):
  IP address: 192.168.1.2
Platform: cisco WS-C3560-48TS,  Capabilities: Switch IGMP
Interface: FastEthernet0/1,  Port ID (outgoing port): FastEthernet0/1
Holdtime : 139 sec

Version :
Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 12.2(55)SE3,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Thu 05-May-11 16:14 by prod_rel_team

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0000000
0FFFFFFFF010221FF000000000000002304A35C80FF0000
VTP Management Domain: ''
Native VLAN: 20 (Mismatch)
Duplex: full
Management address(es):
  IP address: 192.168.1.2

C2950#
C2950#sh cdp neighbors detail
-------------------------
Device ID: C3560
Entry address(es):
  IP address: 192.168.1.2
Platform: cisco WS-C3560-48TS,  Capabilities: Switch IGMP
Interface: FastEthernet0/1,  Port ID (outgoing port): FastEthernet0/1
Holdtime : 165 sec

Version :
Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 12.2(55)SE3,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Thu 05-May-11 16:14 by prod_rel_team

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0000000
0FFFFFFFF010221FF000000000000002304A35C80FF0000
VTP Management Domain: ''
Native VLAN: 20
Duplex: full
Management address(es):
  IP address: 192.168.1.2

C2950#
================================================================================
C3560#sh vtp status
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 :
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : 0023.04a3.5c80
Configuration last modified by 0.0.0.0 at 3-1-93 00:03:01
Local updater ID is 192.168.1.2 on interface Vl20 (lowest numbered VLAN interfac
e found)

Feature VLAN:
--------------
VTP Operating Mode                : Server
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 6
Configuration Revision            : 1
MD5 digest                        : 0x05 0x05 0xF4 0x88 0xCB 0x99 0xA9 0x58
                                    0xD8 0xF6 0xC7 0xE0 0x38 0xCB 0x72 0x72
C3560#
C3560#sh cdp neighbors detail
-------------------------
Device ID: C2950
Entry address(es):
  IP address: 192.168.1.1
Platform: cisco WS-C2950T-24,  Capabilities: Switch IGMP
Interface: FastEthernet0/1,  Port ID (outgoing port): FastEthernet0/1
Holdtime : 151 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA14, RELEASE SOFTWA
RE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by cisco Systems, Inc.
Compiled Tue 26-Oct-10 10:35 by nburra

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0000000
0FFFFFFFF010221FF000000000000001120296800FF0000
VTP Management Domain: 'Building01'
Native VLAN: 10
Duplex: full
Management address(es):
  IP address: 192.168.1.1

C3560#
================================================================================
C3560#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
C3560(config)#vtp domain Building01
Changing VTP domain name from NULL to Building01
C3560(config)#end
C3560#
*Mar  1 00:08:10.607: %SW_VLAN-6-VTP_DOMAIN_NAME_CHG: VTP domain name changed to Building01.
C3560#
C3560#sh cdp neighbors detail
-------------------------
Device ID: C2950
Entry address(es):
  IP address: 192.168.1.1
Platform: cisco WS-C2950T-24,  Capabilities: Switch IGMP
Interface: FastEthernet0/1,  Port ID (outgoing port): FastEthernet0/1
Holdtime : 120 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA14, RELEASE SOFTWA
RE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by cisco Systems, Inc.
Compiled Tue 26-Oct-10 10:35 by nburra

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0000000
0FFFFFFFF010221FF000000000000001120296800FF0000
VTP Management Domain: 'Building01'
Native VLAN: 10
Duplex: full
Management address(es):
  IP address: 192.168.1.1

C3560#
================================================================================
C2950#
00:10:10: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/1 (10), with C3560 FastEthernet0/1 (20).
C2950#
C2950#sh cdp neighbors detail
-------------------------
Device ID: C3560
Entry address(es):
  IP address: 192.168.1.2
Platform: cisco WS-C3560-48TS,  Capabilities: Switch IGMP
Interface: FastEthernet0/1,  Port ID (outgoing port): FastEthernet0/1
Holdtime : 174 sec

Version :
Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 12.2(55)SE3,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Thu 05-May-11 16:14 by prod_rel_team

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0000000
0FFFFFFFF010221FF000000000000002304A35C80FF0000
VTP Management Domain: 'Building01'
Native VLAN: 20 (Mismatch)
Duplex: full
Management address(es):
  IP address: 192.168.1.2

C2950#
================================================================================
C3560#
*Mar  1 00:09:17.943: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/1 (20), with C2950 FastEthernet0/1 (10).
C3560#
C3560#sh cdp neighbors detail
-------------------------
Device ID: C2950
Entry address(es):
  IP address: 192.168.1.1
Platform: cisco WS-C2950T-24,  Capabilities: Switch IGMP
Interface: FastEthernet0/1,  Port ID (outgoing port): FastEthernet0/1
Holdtime : 170 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA14, RELEASE SOFTWA
RE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by cisco Systems, Inc.
Compiled Tue 26-Oct-10 10:35 by nburra

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0000000
0FFFFFFFF010221FF000000000000001120296800FF0000
VTP Management Domain: 'Building01'
Native VLAN: 10 (Mismatch)
Duplex: full
Management address(es):
  IP address: 192.168.1.1

C3560#
================================================================================
C2950#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
C2950(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.
C2950(config)#end
C2950#
================================================================================
C3560#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
C3560(config)#vtp mode transparent
Setting device to VTP Transparent mode for VLANS.
C3560(config)#end
C3560#
================================================================================
C2950#
00:11:10: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/1 (10), with C3560 FastEthernet0/1 (20).
C2950#
C2950#sh vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 250
Number of existing VLANs        : 6
VTP Operating Mode              : Transparent
VTP Domain Name                 : Building01
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x64 0xC2 0xA5 0x9E 0xD5 0x82 0x31 0xC4
Configuration last modified by 0.0.0.0 at 3-1-93 00:03:55
C2950#
C2950#sh cdp neighbors detail
-------------------------
Device ID: C3560
Entry address(es):
  IP address: 192.168.1.2
Platform: cisco WS-C3560-48TS,  Capabilities: Switch IGMP
Interface: FastEthernet0/1,  Port ID (outgoing port): FastEthernet0/1
Holdtime : 158 sec

Version :
Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 12.2(55)SE3,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Thu 05-May-11 16:14 by prod_rel_team

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0000000
0FFFFFFFF010221FF000000000000002304A35C80FF0000
VTP Management Domain: 'Building01'
Native VLAN: 20 (Mismatch)
Duplex: full
Management address(es):
  IP address: 192.168.1.2

C2950#
================================================================================
C3560#
*Mar  1 00:10:17.946: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/1 (20), with C2950 FastEthernet0/1 (10).
C3560#
C3560#sh vtp status
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 : Building01
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : 0023.04a3.5c80
Configuration last modified by 0.0.0.0 at 3-1-93 00:03:01

Feature VLAN:
--------------
VTP Operating Mode                : Transparent
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 6
Configuration Revision            : 0
MD5 digest                        : 0x7F 0x33 0x0C 0xC9 0x6B 0x97 0x4A 0x32
                                    0x85 0xF3 0x6F 0xD4 0xEA 0x78 0xEB 0x6B
C3560#
C3560#sh cdp neighbors detail
-------------------------
Device ID: C2950
Entry address(es):
  IP address: 192.168.1.1
Platform: cisco WS-C2950T-24,  Capabilities: Switch IGMP
Interface: FastEthernet0/1,  Port ID (outgoing port): FastEthernet0/1
Holdtime : 158 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA14, RELEASE SOFTWA
RE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by cisco Systems, Inc.
Compiled Tue 26-Oct-10 10:35 by nburra

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0000000
0FFFFFFFF010221FF000000000000001120296800FF0000
VTP Management Domain: 'Building01'
Native VLAN: 10 (Mismatch)
Duplex: full
Management address(es):
  IP address: 192.168.1.1

C3560#
================================================================================
C3560#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
C3560(config)#int fa0/1
C3560(config-if)#no cdp enable
C3560(config-if)#end
C3560#
================================================================================
C2950#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
C3560            Fas 0/1            75           S I      WS-C3560-4Fas 0/1
C2950#
================================================================================
C3560#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
C2950            Fas 0/1           81               S I   WS-C2950T Fas 0/1
C3560#
================================================================================
C2950#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
C3560            Fas 0/1            0            S I      WS-C3560-4Fas 0/1
C2950#
C2950#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
C2950#
================================================================================
C3560#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
C2950            Fas 0/1           0                S I   WS-C2950T Fas 0/1
C3560#
C3560#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
C3560#

No comments:

Post a Comment