Wednesday, May 18, 2011

Catalyst 2950 PAgP Partner Information Cosmetic Bug

Bug Description:
The last character of the Partner Name and Partner Port information in the output of the show etherchannel port EXEC command on Catalyst 2950 Series switches is truncated.
The information is carried in the Device Name and Physical Port Name TLVs in the PAgP packets.
This is applicable for PAgP only.
First found in c2950-i6k2l2q4-mz.121-22.EA10a.bin.



C2950#sh ver | in IOS|Compiled
IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA14, RELEASE SOFTWARE (fc1)
Compiled Tue 26-Oct-10 10:35 by nburra
C2950#
C2950#sh run int fa0/9
Building configuration...

Current configuration : 88 bytes
!
interface FastEthernet0/9
 switchport mode trunk
 channel-group 1 mode desirable
end

C2950#
C2950#sh run int fa0/10
Building configuration...

Current configuration : 89 bytes
!
interface FastEthernet0/10
 switchport mode trunk
 channel-group 1 mode desirable
end

C2950#
C2950#sh run int po1
Building configuration...

Current configuration : 54 bytes
!
interface Port-channel1
 switchport mode trunk
end

C2950#
================================================================================
C3560#sh run int fa0/9
Building configuration...

Current configuration : 126 bytes
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
end

C3560#
C3560#sh run int fa0/10
Building configuration...

Current configuration : 127 bytes
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
end

C3560#
C3560#sh run int po1
Building configuration...

Current configuration : 92 bytes
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

C3560#



C2950#
00:14:33: %LINK-3-UPDOWN: Interface FastEthernet0/9, changed state to up
00:14:34: %LINK-3-UPDOWN: Interface FastEthernet0/10, changed state to up
00:14:37: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/9, changed state to up
00:14:38: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to up
00:14:38: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:14:39: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
C2950#
C2950#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
C3560            Fas 0/10           179          S I      WS-C3560-4Fas 0/10
C3560            Fas 0/9            179          S I      WS-C3560-4Fas 0/9
C2950#
C2950#sh etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Fa0/9(Pd)   Fa0/10(P)

C2950#
C2950#sh etherchannel port
                Channel-group listing:
                ----------------------

Group: 1
----------
                Ports in the group:
                -------------------
Port: Fa0/9
------------

Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = Desirable-Sl    Gcchange = 0
Port-channel  = Po1         GC   = 0x00010001      Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   PAgP

Flags:  S - Device is sending Slow hello.  C - Device is in Consistent state.
        A - Device is in Auto mode.        P - Device learns on physical port.
        d - PAgP is down.
Timers: H - Hello timer is running.        Q - Quit timer is running.
        S - Switching timer is running.    I - Interface timer is running.

Local information:
                                Hello    Partner  PAgP     Learning  Group
Port      Flags State   Timers  Interval Count   Priority   Method  Ifindex
Fa0/9     SC    U6/S7   H       30s      1        128        Any      29

Partner's information:

          Partner              Partner          Partner         Partner Group
Port      Name                 Device ID        Port       Age  Flags   Cap.
Fa0/9     C356                 0023.04a3.5c80   Fa0/         8s SC      10001

Age of the port in the current state: 0d:00h:00m:09s

Port: Fa0/10
------------

Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = Desirable-Sl    Gcchange = 0
Port-channel  = Po1         GC   = 0x00010001      Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   PAgP

Flags:  S - Device is sending Slow hello.  C - Device is in Consistent state.
        A - Device is in Auto mode.        P - Device learns on physical port.
        d - PAgP is down.
Timers: H - Hello timer is running.        Q - Quit timer is running.
        S - Switching timer is running.    I - Interface timer is running.

Local information:
                                Hello    Partner  PAgP     Learning  Group
Port      Flags State   Timers  Interval Count   Priority   Method  Ifindex
Fa0/10    SC    U6/S7   H       30s      1        128        Any      29

Partner's information:

          Partner              Partner          Partner         Partner Group
Port      Name                 Device ID        Port       Age  Flags   Cap.
Fa0/10    C356                 0023.04a3.5c80   Fa0/1        9s SC      10001

Age of the port in the current state: 0d:00h:00m:09s


C2950#
C2950#sh etherchannel port-channel
                Channel-group listing:
                ----------------------

Group: 1
----------
                Port-channels in the group:
                ---------------------------

Port-channel: Po1
------------

Age of the Port-channel   = 0d:00h:06m:08s
Logical slot/port   = 1/0          Number of ports = 2
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   PAgP

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Fa0/9    Desirable-Sl       0
  0     00     Fa0/10   Desirable-Sl       0

Time since last port bundled:    0d:00h:00m:10s    Fa0/10

C2950#
================================================================================
C3560#
00:13:41.320: %LINK-3-UPDOWN: Interface FastEthernet0/9, changed state to up
00:13:41.949: %LINK-3-UPDOWN: Interface FastEthernet0/10, changed state to up
00:13:45.304: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/9, changed state to up
00:13:45.967: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to up
00:13:46.286: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:13:47.292: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
C3560#
C3560#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
C2950            Fas 0/10          169              S I   WS-C2950T Fas 0/10
C2950            Fas 0/9           168              S I   WS-C2950T Fas 0/9
C3560#
C3560#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Fa0/9(P)    Fa0/10(P)

C3560#
C3560#sh etherchannel port
                Channel-group listing:
                ----------------------

Group: 1
----------
                Ports in the group:
                -------------------
Port: Fa0/9
------------

Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = Desirable-Sl    Gcchange = 0
Port-channel  = Po1         GC   = 0x00010001      Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   PAgP

Flags:  S - Device is sending Slow hello.  C - Device is in Consistent state.
        A - Device is in Auto mode.        P - Device learns on physical port.
        d - PAgP is down.
Timers: H - Hello timer is running.        Q - Quit timer is running.
        S - Switching timer is running.    I - Interface timer is running.

Local information:
                                Hello    Partner  PAgP     Learning  Group
Port      Flags State   Timers  Interval Count   Priority   Method  Ifindex
Fa0/9     SC    U6/S7   H       30s      1        128        Any      5001

Partner's information:

          Partner              Partner          Partner         Partner Group
Port      Name                 Device ID        Port       Age  Flags   Cap.
Fa0/9     C2950                0011.2029.6800   Fa0/9       13s SC      10001

Age of the port in the current state: 0d:00h:00m:13s

Port: Fa0/10
------------

Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = Desirable-Sl    Gcchange = 0
Port-channel  = Po1         GC   = 0x00010001      Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   PAgP

Flags:  S - Device is sending Slow hello.  C - Device is in Consistent state.
        A - Device is in Auto mode.        P - Device learns on physical port.
        d - PAgP is down.
Timers: H - Hello timer is running.        Q - Quit timer is running.
        S - Switching timer is running.    I - Interface timer is running.

Local information:
                                Hello    Partner  PAgP     Learning  Group
Port      Flags State   Timers  Interval Count   Priority   Method  Ifindex
Fa0/10    SC    U6/S7   H       30s      1        128        Any      5001

Partner's information:

          Partner              Partner          Partner         Partner Group
Port      Name                 Device ID        Port       Age  Flags   Cap.
Fa0/10    C2950                0011.2029.6800   Fa0/10      14s SC      10001

Age of the port in the current state: 0d:00h:00m:13s


C3560#
C3560#sh etherchannel port-channel
                Channel-group listing:
                ----------------------

Group: 1
----------
                Port-channels in the group:
                ---------------------------

Port-channel: Po1
------------

Age of the Port-channel   = 0d:00h:05m:42s
Logical slot/port   = 2/1          Number of ports = 2
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   PAgP
Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Fa0/9    Desirable-Sl       0
  0     00     Fa0/10   Desirable-Sl       0

Time since last port bundled:    0d:00h:00m:15s    Fa0/10

C3560#



Below shows the command output for the same network setup with LACP for the sake of completeness and comparison. :-)

C2950#sh run int fa0/9
Building configuration...

Current configuration : 85 bytes
!
interface FastEthernet0/9
 switchport mode trunk
 channel-group 1 mode active
end

C2950#
C2950#sh run int fa0/10
Building configuration...

Current configuration : 86 bytes
!
interface FastEthernet0/10
 switchport mode trunk
 channel-group 1 mode active
end

C2950#
C2950#sh run int po1
Building configuration...

Current configuration : 54 bytes
!
interface Port-channel1
 switchport mode trunk
end

C2950#
00:22:08: %LINK-3-UPDOWN: Interface FastEthernet0/9, changed state to up
00:22:08: %LINK-3-UPDOWN: Interface FastEthernet0/10, changed state to up
00:22:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/9, changed state to up
00:22:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to up
00:22:13: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:22:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
C2950#
C2950#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
C3560            Fas 0/10           175          S I      WS-C3560-4Fas 0/10
C3560            Fas 0/9            175          S I      WS-C3560-4Fas 0/9
C2950#
C2950#sh etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Fa0/9(Pd)   Fa0/10(P)

C2950#
C2950#sh etherchannel port
                Channel-group listing:
                ----------------------

Group: 1
----------
                Ports in the group:
                -------------------
Port: Fa0/9
------------

Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = Active          Gcchange = -
Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port     Port
Port      Flags   State     Priority      Key       Key     Number   State
Fa0/9     SA      bndl      32768         0x1       0x1     0x9      0x3D

Partner's information:

                  LACP port                        Oper    Port     Port
Port      Flags   Priority  Dev ID         Age     Key     Number   State
Fa0/9     SA      32768     0023.04a3.5c80   9s    0x1     0x10C    0x3D

Age of the port in the current state: 0d:00h:00m:08s

Port: Fa0/10
------------

Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = Active          Gcchange = -
Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port     Port
Port      Flags   State     Priority      Key       Key     Number   State
Fa0/10    SA      bndl      32768         0x1       0x1     0xA      0x3D

Partner's information:

                  LACP port                        Oper    Port     Port
Port      Flags   Priority  Dev ID         Age     Key     Number   State
Fa0/10    SA      32768     0023.04a3.5c80   9s    0x1     0x10D    0x3D

Age of the port in the current state: 0d:00h:00m:08s


C2950#
C2950#sh etherchannel port-channel
                Channel-group listing:
                ----------------------

Group: 1
----------
                Port-channels in the group:
                ---------------------------

Port-channel: Po1    (Primary Aggregator)

------------

Age of the Port-channel   = 0d:00h:01m:25s
Logical slot/port   = 1/0          Number of ports = 2
HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   LACP

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Fa0/9    Active             0
  0     00     Fa0/10   Active             0

Time since last port bundled:    0d:00h:00m:10s    Fa0/10

C2950#
================================================================================
C3560#sh run int fa0/9
Building configuration...

Current configuration : 123 bytes
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode active
end

C3560#
C3560#sh run int fa0/10
Building configuration...

Current configuration : 124 bytes
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode active
end

C3560#
C3560#sh run int po1
Building configuration...

Current configuration : 92 bytes
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

C3560#
00:21:15.848: %LINK-3-UPDOWN: Interface FastEthernet0/9, changed state to up
00:21:16.519: %LINK-3-UPDOWN: Interface FastEthernet0/10, changed state to up
00:21:19.883: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/9, changed state to up
00:21:20.588: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to up
00:21:20.864: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:21:21.871: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
C3560#
C3560#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
C2950            Fas 0/10          178              S I   WS-C2950T Fas 0/10
C2950            Fas 0/9           178              S I   WS-C2950T Fas 0/9
C3560#
C3560#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Fa0/9(P)    Fa0/10(P)

C3560#
C3560#sh etherchannel port
                Channel-group listing:
                ----------------------

Group: 1
----------
                Ports in the group:
                -------------------
Port: Fa0/9
------------

Port state    = Up Mstr Assoc In-Bndl
Channel group = 1           Mode = Active          Gcchange = -
Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Fa0/9     SA      bndl      32768         0x1       0x1     0x10C       0x3D

Partner's information:

                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Fa0/9     SA      32768     0011.2029.6800  12s    0x0    0x1    0x9     0x3D

Age of the port in the current state: 0d:00h:00m:11s

Port: Fa0/10
------------

Port state    = Up Mstr Assoc In-Bndl
Channel group = 1           Mode = Active          Gcchange = -
Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Fa0/10    SA      bndl      32768         0x1       0x1     0x10D       0x3D

Partner's information:

                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Fa0/10    SA      32768     0011.2029.6800  13s    0x0    0x1    0xA     0x3D

Age of the port in the current state: 0d:00h:00m:12s


C3560#
C3560#sh etherchannel port-channel
                Channel-group listing:
                ----------------------

Group: 1
----------
                Port-channels in the group:
                ---------------------------

Port-channel: Po1    (Primary Aggregator)

------------

Age of the Port-channel   = 0d:00h:01m:12s
Logical slot/port   = 2/1          Number of ports = 2
HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   LACP
Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Fa0/9    Active             0
  0     00     Fa0/10   Active             0

Time since last port bundled:    0d:00h:00m:13s    Fa0/10

C3560#

2 comments: